WebGL ripping of a model from sketchfab

Post questions about game models here, or help out others!
awnimator
ultra-n00b
Posts: 2
Joined: Thu Sep 20, 2018 2:54 am

Re: WebGL ripping of a model from sketchfab

Post by awnimator » Thu Sep 20, 2018 5:40 pm

i got a problem, any models that i convert comes with lots of triangulated poly, totally diferent from the sketchfab's wireframe, anyone have any idea on how to fix it?

PleasantPeasant
ultra-n00b
Posts: 3
Joined: Wed Jul 04, 2018 3:27 pm

Re: WebGL ripping of a model from sketchfab

Post by PleasantPeasant » Fri Sep 21, 2018 12:24 pm

Does anyone know if NinjaRipper still works with Artstation?

User avatar
Zaczac121
beginner
Posts: 31
Joined: Wed Oct 04, 2017 8:19 pm
Location: United Kingdom
Has thanked: 7 times
Been thanked: 1 time

Re: WebGL ripping of a model from sketchfab

Post by Zaczac121 » Fri Sep 21, 2018 7:58 pm

Could someone rip this model for me? https://sketchfab.com/models/5935d88690 ... 2abccc679a

Sadtin
ultra-n00b
Posts: 1
Joined: Sat Sep 22, 2018 6:14 am

Re: WebGL ripping of a model from sketchfab

Post by Sadtin » Sat Sep 22, 2018 6:27 am

I can't seem to get the textures for a model, i've tried everything i could find to no avail, i'd really apreciate some help on the mather if possible, model is nsfw+fur not sure if i should just post it straight away or wait for a reply, but i'll go for the latter for now just to be safe.

froggy17500
ultra-n00b
Posts: 1
Joined: Sat Sep 22, 2018 5:37 pm

Re: WebGL ripping of a model from sketchfab

Post by froggy17500 » Sat Sep 22, 2018 5:38 pm

Could someone rip this for me please?
https://sketchfab.com/models/ea0c7bd5d6 ... 6e1f53fd86

User avatar
nnnobbbody
n00b
Posts: 15
Joined: Sun Apr 03, 2016 9:19 am
Location: EUSSR
Has thanked: 6 times
Been thanked: 12 times

Re: WebGL ripping of a model from sketchfab

Post by nnnobbbody » Sat Sep 22, 2018 10:05 pm

Sadtin wrote:I can't seem to get the textures for a model, i've tried everything i could find to no avail,
Look at "Triangles: ... Vertices: etc" and click on "More model information"
See if it has any textures or if it uses vertex color. If it uses vertex color we don't have a proper method, but it is technically possible. See my previous post a page ago or so.
Sadtin wrote:model is nsfw+fur not sure if i should just post it straight away or wait for a reply, but i'll go for the latter for now just to be safe
If it's furry porn, I'm interested. I may even already have it.

Just use the

Code: Select all

 brackets and post a NSFW disclaimer inside, next to the link.
Or send it to me in a private message.

[quote="awnimator"]i got a problem, any models that i convert comes with lots of triangulated poly, totally diferent from the sketchfab's wireframe, anyone have any idea on how to fix it?[/quote]
Send us a few screenshots, please. Original model vs ripped model.

[quote="PleasantPeasant"]Does anyone know if NinjaRipper still works with Artstation?[/quote]
Aren't ArtStation models still stored in Marmoset .mview models? There's an open source model extracting script somewhere and it actually works well. You can also preview and extract them in Noesis I think, but texture extraction isn't optimal with Noesis, use the script.
~~~ "To learn who rules over you, simply find out who you are not allowed to criticise" ~~~

sapowor
ultra-n00b
Posts: 2
Joined: Tue Aug 14, 2018 9:24 pm
Has thanked: 1 time
Been thanked: 1 time

Re: WebGL ripping of a model from sketchfab

Post by sapowor » Mon Sep 24, 2018 7:00 am

Are people still doing requests?

https://sketchfab.com/models/2b98ee8df2 ... e670cd856c

Just to 3d print as a gift

would greatly appreciate it!

HerpeusVonDerpeus
ultra-n00b
Posts: 1
Joined: Tue Sep 25, 2018 2:55 am

Re: WebGL ripping of a model from sketchfab

Post by HerpeusVonDerpeus » Tue Sep 25, 2018 3:00 am

Hi all,

Is it possible to rip from this site?
https://human.biodigital.com/index.html

Would like to use it as reference material for 3D work I'm doing.

ranger561
ultra-n00b
Posts: 4
Joined: Tue Sep 18, 2018 11:54 am

Re: WebGL ripping of a model from sketchfab

Post by ranger561 » Tue Sep 25, 2018 4:53 am

can some one send me the method of ripping models that work plz.As we can not detect link here. I Will be ever in your deat and will not abuse this

gulupao
ultra-n00b
Posts: 4
Joined: Mon Sep 10, 2018 10:17 am

Re: WebGL ripping of a model from sketchfab

Post by gulupao » Tue Sep 25, 2018 11:37 am

can some one help?
what is the problem with this?
https://sketchfab.com/models/e39bbeb0b8 ... 8587c8d4ee
1.jpg
You do not have the required permissions to view the files attached to this post.

episoder
mega-veteran
mega-veteran
Posts: 203
Joined: Fri Oct 16, 2015 8:05 pm
Has thanked: 4 times
Been thanked: 87 times

Re: WebGL ripping of a model from sketchfab

Post by episoder » Tue Sep 25, 2018 1:51 pm

gulupao wrote:can some one help?
what is the problem with this?
https://sketchfab.com/models/e39bbeb0b8 ... 8587c8d4ee
-snip-
i dunno. lil decoder error perhaps. faulty origin rotations/locations. it's a lot of submesh data. it seems the model is atleast one half complete and symmetrical. you could just duplicate and mirror the faulty parts. after you applied all those origins and maybe merged a lot of the materials, ofc. i mean, it could be 'just' a 6-7 colors/materials model not a 1000+ thing. the script doesn't use the osg materials tho. bummer.
I don't rip for private requests. Ask in the forum or forget about it. :]

gulupao
ultra-n00b
Posts: 4
Joined: Mon Sep 10, 2018 10:17 am

Re: WebGL ripping of a model from sketchfab

Post by gulupao » Wed Sep 26, 2018 2:51 am

episoder wrote:
gulupao wrote:can some one help?
what is the problem with this?
https://sketchfab.com/models/e39bbeb0b8 ... 8587c8d4ee
-snip-
i dunno. lil decoder error perhaps. faulty origin rotations/locations. it's a lot of submesh data. it seems the model is atleast one half complete and symmetrical. you could just duplicate and mirror the faulty parts. after you applied all those origins and maybe merged a lot of the materials, ofc. i mean, it could be 'just' a 6-7 colors/materials model not a 1000+ thing. the script doesn't use the osg materials tho. bummer.
no.
although the model appears to be symmetrical, there are actually many problems.and because there are too many meshes, I can’t handle them.

gulupao
ultra-n00b
Posts: 4
Joined: Mon Sep 10, 2018 10:17 am

Re: WebGL ripping of a model from sketchfab

Post by gulupao » Wed Sep 26, 2018 11:40 am

episoder wrote:
gulupao wrote:can some one help?
what is the problem with this?
https://sketchfab.com/models/e39bbeb0b8 ... 8587c8d4ee
-snip-
i dunno. lil decoder error perhaps. faulty origin rotations/locations. it's a lot of submesh data. it seems the model is atleast one half complete and symmetrical. you could just duplicate and mirror the faulty parts. after you applied all those origins and maybe merged a lot of the materials, ofc. i mean, it could be 'just' a 6-7 colors/materials model not a 1000+ thing. the script doesn't use the osg materials tho. bummer.
I modified start.py. It seems that the problem is solved, but I don't know why.

User avatar
M0fD
mega-veteran
mega-veteran
Posts: 208
Joined: Sat Nov 01, 2014 10:05 pm
Location: Les Gobelins
Has thanked: 19 times
Been thanked: 34 times

Re: WebGL ripping of a model from sketchfab

Post by M0fD » Wed Sep 26, 2018 11:55 am

gulupao wrote:I modified start.py. It seems that the problem is solved, but I don't know why.
Can't try for the moment but if you have modified the starter.py telle us how so we can try to understand.
1. Ninja Ripper doesn't work with Sketchfab

2. Don't distribute the extraction method

3. Three models only

4. No buyable models


Image

gulupao
ultra-n00b
Posts: 4
Joined: Mon Sep 10, 2018 10:17 am

Re: WebGL ripping of a model from sketchfab

Post by gulupao » Wed Sep 26, 2018 12:12 pm

M0fD wrote:
gulupao wrote:I modified start.py. It seems that the problem is solved, but I don't know why.
Can't try for the moment but if you have modified the starter.py telle us how so we can try to understand.
Modify the "osgParser" method
QQ20180926-190810@2x.png
I tested 3 problematic models,the problem is solved.
but I am a java programmer,so I don't know what the problem is.
You do not have the required permissions to view the files attached to this post.

Post Reply