Page 1 of 2

Should we upgrade the forum to phpBB 3.2.5?

Posted: Sun Feb 10, 2019 8:28 pm
by Mr.Mouse
Hi everyone,

A quick poll to ask you XeNTaX members if you are okay with upgrading the forum to phpBB 3.2.5 (the latest).
This means the style will become Prosilver, and I may not be able to retain the Thanks for Posts functionality.

However, it will add a heap of other stuff and fix some longstanding issues.

Let me know in the poll!

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Sun Feb 10, 2019 9:47 pm
by Dinoguy1000
If you vote "no", it would help if you also leave a comment explaining your reasoning a bit better.

From a security perspective, I think the forum should be upgraded regardless; the only reason we haven't been pwned by a security exploit that was patched in some later version of phpBB is probably largely down to luck (though admittedly I haven't read through the changelogs for the releases between our version and the latest, so any patched security issues might be more theoretical than actual).

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Sat Feb 16, 2019 10:55 pm
by Mr.Mouse
it is done ! :) [bruce]

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Sun Feb 17, 2019 12:43 am
by mono24
30years young and a new facelift, how nice is this, thank you for your continuum support and longevity of the forum gents.
I am proud to call this my home and to be able to spend time here when I can, and help with what I can other users as well.

Cheers.

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Sun Feb 17, 2019 3:10 am
by rengareng
Is there any future plan to use https?

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Sun Feb 17, 2019 10:11 am
by Mr.Mouse
rengareng wrote:
Sun Feb 17, 2019 3:10 am
Is there any future plan to use https?
Yes it's back on now. Hadn't done that yet. :)

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Tue Feb 19, 2019 3:48 am
by Bigchillghost
Is there a reason why the connection appears to be not secure in Firefox?
security.jpg

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Wed Feb 20, 2019 4:02 pm
by zaykho
: [ Damn I should have seen this poll before.

I voted
No, I don't like the Prosilver style.
I will say that, I prefer the old style, it was less common and more "xentax". Right now it look like way too generic and too bland.

Like we are used to say : " It was better before " :(

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Thu Feb 21, 2019 10:46 pm
by Mr.Mouse
Bigchillghost wrote:
Tue Feb 19, 2019 3:48 am
Is there a reason why the connection appears to be not secure in Firefox?
security.jpg
Yes, because users posted images that were uploaded at non-SSL locations. Since we have many posts here, there will always be posts that link to a site with http instead of https. We can force those URLs to link to https instead, but that will only work if those sites actually have https.

So if you link to an image in your post from a site that is not secure, this forum will be marked as having Mixed Content.
Basically the devs of Firefox think it is good to mark forums like this as Mixed Content with a warning, because someone posted a link to a non-secure site in a post. Thus, many forums have this warning. Of course, better browers would simply block malware appearing through an image and not nag about this, making a secure site look bad. On the other hand, we could probably force users to only post images when from a secure site.
Oh well.

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Thu Feb 21, 2019 10:52 pm
by Mr.Mouse
zaykho wrote:
Wed Feb 20, 2019 4:02 pm
: [ Damn I should have seen this poll before.

I voted
No, I don't like the Prosilver style.
I will say that, I prefer the old style, it was less common and more "xentax". Right now it look like way too generic and too bland.

Like we are used to say : " It was better before " :(
Yeah, if there are people willing to build a new template, let them step forward. It should be easily turned on or off, as a requirement.

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Sat Feb 23, 2019 6:10 am
by Bigchillghost
Mr.Mouse wrote:
Thu Feb 21, 2019 10:46 pm
Basically the devs of Firefox think it is good to mark forums like this as Mixed Content with a warning, because someone posted a link to a non-secure site in a post. Thus, many forums have this warning.
I see. So long as there's no actual security issue it's fine with me. [roll]
Thanks again for the clarification.

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Sat Feb 23, 2019 6:37 am
by Dinoguy1000
Bigchillghost wrote:
Sat Feb 23, 2019 6:10 am
I see. So long as there's no actual security issue it's fine with me. [roll]
Thanks again for the clarification.
If you feel like it, you can always go through your old posts and check any images, updating them to HTTPS where possible (or reuploading them to a service with HTTPS support and updating the relevant post(s) accordingly). Obviously this won't make a huge difference, but it's still something, and anyone can do this with their own posts.

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Sat Feb 23, 2019 12:40 pm
by Bigchillghost
Dinoguy1000 wrote:
Sat Feb 23, 2019 6:37 am
If you feel like it, you can always go through your old posts and check any images, updating them to HTTPS where possible (or reuploading them to a service with HTTPS support and updating the relevant post(s) accordingly).
It's done. :roll:
One problem remains though. I can't change what other users already quoted from my old posts.
Dinoguy1000 wrote:
Sat Feb 23, 2019 6:37 am
Obviously this won't make a huge difference, but it's still something, and anyone can do this with their own posts.
If there're some tricks that can help users locate to those posts easier, maybe they'll have more desire to do it. Otherwise it would be a huge pain to figure out in which post one could ever placed an insecure link.

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Sun Feb 24, 2019 5:19 pm
by zaykho
Mr.Mouse wrote:
Thu Feb 21, 2019 10:52 pm

Yeah, if there are people willing to build a new template, let them step forward. It should be easily turned on or off, as a requirement.
Do we still have access/picture from the old theme ?

I never made a template with PHPbb before, but I'm a web developer, so I don't think it will be that much of a trouble. ( I can already make a stylus addon script if needed. )

Re: Should we upgrade the forum to phpBB 3.2.5?

Posted: Mon Feb 25, 2019 3:03 am
by Dinoguy1000
Bigchillghost wrote:
Sat Feb 23, 2019 12:40 pm
One problem remains though. I can't change what other users already quoted from my old posts.
Aah, good point... If I had a good handle on how the report system works, I would suggest to report those posts so mod could update the link(s) in them (this would also work for any other posts). However, if reporting impacts the poster's account in some way (e.g. if we had a karma system, and reported posts counted as negative karma), this wouldn't work so well.
Bigchillghost wrote:
Sat Feb 23, 2019 12:40 pm
If there're some tricks that can help users locate to those posts easier, maybe they'll have more desire to do it. Otherwise it would be a huge pain to figure out in which post one could ever placed an insecure link.
There's none I'm aware of, unfortunately. It's somewhat easier if the person hasn't posted many images over time, but that'll be small consolation to active image posters who want to help clean up their own post history. At least you can view all of your posts from your profile... kind of. phpBB just isn't designed for this type of thing.
zaykho wrote:
Sun Feb 24, 2019 5:19 pm
Do we still have access/picture from the old theme ?

I never made a template with PHPbb before, but I'm a web developer, so I don't think it will be that much of a trouble. ( I can already make a stylus addon script if needed. )
Your best bet would be probably to see what's available on the Internet Archive; that way, you could grab the actual HTML/CSS instead of just having to recreate the appearance from screenshots.