READ THE RULES: Click here

Follow us on Facebook: https://www.facebook.com/xentax/ :)

Custom GMA/TPL help...

Get your graphics formats figures out here! Got details for others? Post here!
Post Reply
Yoshimaster96
ultra-n00b
Posts: 3
Joined: Sun Nov 23, 2014 5:57 pm

Custom GMA/TPL help...

Post by Yoshimaster96 » Sun Nov 23, 2014 6:18 pm

Need help with making custom GMA/TPL model/texture files. I got so far, but only one texture shows for some reason. Help!
FUNNEL.zip
You do not have the required permissions to view the files attached to this post.

User avatar
mugi
beginner
Posts: 32
Joined: Wed Mar 23, 2011 8:02 pm
Has thanked: 3 times
Been thanked: 9 times

Re: Custom GMA/TPL help...

Post by mugi » Fri Dec 19, 2014 3:09 pm

i took a peek at the graphics and they look rather simple as is, aside the fact that they seem to lack a palette (in a different file i'd assume)
here's what i found out:

Image

judging from the data pattern, this format is tiled.

grey: number of graphics entries (0x2)
red: there's 3 of these per file;
--- first is unknown, i'd believe it's a mode flag,
--- second is the data start address (0x40 for first file)(0x840 for second file)
--- resolution of the file 2x2byte value (0x20 0x20 // 32x32 pixels for both of them)
blue: unknown
yellow: seems to be header filler/garbage data.
You do not have the required permissions to view the files attached to this post.

Yoshimaster96
ultra-n00b
Posts: 3
Joined: Sun Nov 23, 2014 5:57 pm

Re: Custom GMA/TPL help...

Post by Yoshimaster96 » Sun Dec 28, 2014 3:23 am


Post Reply