Join also our Discord channel! Click here.

Telltale Games "Almost-All-In-One" Model Importer

Post questions about game models here, or help out others!
RandomTBush
ultra-veteran
ultra-veteran
Posts: 321
Joined: Thu May 13, 2010 4:11 pm
Has thanked: 44 times
Been thanked: 272 times

Re: Telltale Games "Almost-All-In-One" Model Importer

Post by RandomTBush » Thu Jun 25, 2020 8:48 am

frostbone25 wrote:
Wed Jun 24, 2020 5:16 pm
RandomTBush wrote:
Sat Apr 04, 2020 7:09 pm
thongTk wrote:
Sat Apr 04, 2020 12:20 pm
Is the script for the definitive edition still being worked on?
Yeah, I still have plans to work on that.
Hey @RandomTBush , I wanted to notify you the best I can (as a fellow programmer, but not in MaxScript though but I'll do my best) about an issue I stumbled upon when I wanted to import a mesh that is specific to the definitive edition (specifically the menu scene, with Clementine's house which I wanted to extract and prep for others to use just for fun). I'm aware you have plans on updating the script to work properly on definitive edition but you haven't posted any updates in a while.

Anyways, when importing a definitive edition specific mesh It seems like the script is struggling to parse the vertex buffer information from the d3dmesh file. At line 16437 in the script, specifically in 'Section 11C' (good thing you marked it because your script is awfully long), when it enters the switch statement 'MeshFlag1' it fails to hit any of the cases and defaults to your throw statement and of course the rest of the script is unable to proceed then since its unable to parse and set any values regarding the vertex buffer. My guess would be that in the definitive edition, the "MeshFlag1" values you are trying to parse have changed and it's unable to meet any of the cases, or the order in which the file is structured has changed where the data is and its unable to parse it then. I'm currently looking into it the best I can with my prior knowledge and seeing if I can solve it, and if I do ill be sure to let you know, but I wanted to let you know with as much info as I can provide about the issue so that you yourself can find it easily and solve it. Thank you!
frostbone25 wrote:
Wed Jun 24, 2020 8:11 pm
Note: I was able to get the meshes to import by getting rid of the 'throw' exceptions just by commenting them out just to see if the script would be able to import the mesh at all. It worked of course, but that was only a 'bandaid' on the issue and the meshes UV maps unfortunately are messed up, still looking into it though.
Hooray for sloppy coding! I'll be sure to address this properly when I finally get time to work on the script again. Hopefully next month, if things don't go downhill again.

Post Reply