WebGL ripping of a model from sketchfab

Post questions about game models here, or help out others!
Ploxan
ultra-n00b
Posts: 1
Joined: Mon Dec 24, 2018 3:19 am

Re: WebGL ripping of a model from sketchfab

Post by Ploxan » Mon Dec 24, 2018 3:23 am

Is it possible to ripp this model?

https://sketchfab.com/models/c4ea4b117f ... 071a660713

If its possible I would be so happy if someone could teach me or just Rippit

pendave
n00b
Posts: 13
Joined: Fri Jun 26, 2015 10:50 am
Has thanked: 1 time
Been thanked: 1 time

Re: WebGL ripping of a model from sketchfab

Post by pendave » Mon Dec 24, 2018 8:22 am

M0fD wrote:Python26 but you can have both old and new python if you know like me how to switch.
How do you swtich from the old version to the latest one, together with both Python and Blender?
I can only do that on my old laptop, a different machine :]

pendave
n00b
Posts: 13
Joined: Fri Jun 26, 2015 10:50 am
Has thanked: 1 time
Been thanked: 1 time

Re: WebGL ripping of a model from sketchfab

Post by pendave » Mon Dec 24, 2018 9:15 am

So weird, I can't find the textures images either in this

https://sketchfab.com/models/7beb908084 ... 8acbe95125

QQ截图20181224161441.jpg
You do not have the required permissions to view the files attached to this post.

episoder
mega-veteran
mega-veteran
Posts: 193
Joined: Fri Oct 16, 2015 8:05 pm
Has thanked: 4 times
Been thanked: 82 times

Re: WebGL ripping of a model from sketchfab

Post by episoder » Tue Dec 25, 2018 9:38 pm

pendave wrote:So weird, I can't find the textures images either in this

https://sketchfab.com/models/7beb908084 ... 8acbe95125

snip
are you old enough for his? :lol: what sort of browser or extension is this? and yes... the textures don't show up in chrome nor firefox either. this happens sometimes, the recording is a lil off. chrome doesn't even preview the other image files correct on just this model page tho. odd. very odd. you may just have to use the ripper with a pleasant interval to get those.

btw... don't ever tell me to remove the tool post, again. i'm not worried. i wrote the pm before this (anyway). :]

User avatar
chrrox
Moderator
Posts: 2519
Joined: Sun May 18, 2008 3:01 pm
Has thanked: 57 times
Been thanked: 1251 times

Re: WebGL ripping of a model from sketchfab

Post by chrrox » Wed Dec 26, 2018 3:44 am

its all vertex color the only texture is 1 specular texture.
https://media.sketchfab.com/environment ... 500.bin.gz

User avatar
M0fD
mega-veteran
mega-veteran
Posts: 192
Joined: Sat Nov 01, 2014 10:05 pm
Location: Les Gobelins
Has thanked: 19 times
Been thanked: 28 times

Re: WebGL ripping of a model from sketchfab

Post by M0fD » Wed Dec 26, 2018 11:55 pm

Yup, chrrox is right, if there is no textures it's because it's a vertex color model.
episoder wrote:btw... don't ever tell me to remove the tool post, again. i'm not worried. i wrote the pm before this (anyway)
Lol, again with that ? How lame.
Nobody is worried before getting caught anyway.
1. Ninja Ripper doesn't work with Sketchfab

2. Don't distribute the extraction method

3. Three models only

4. No buyable models


ImageImage

episoder
mega-veteran
mega-veteran
Posts: 193
Joined: Fri Oct 16, 2015 8:05 pm
Has thanked: 4 times
Been thanked: 82 times

Re: WebGL ripping of a model from sketchfab

Post by episoder » Thu Dec 27, 2018 2:37 pm

what? you got 2cent to this? ofc. you tried to burn it too. right now... they can't catch me. they can't send me any letters. i will not accept an online c&d, if they'd try that. neither is the tool and being for free an asset they can claim, in the first place. only the author could do that. they could pay me to cease to provide it. think they wanna? :D plus dude's worried about them patching the method. like...
they can only patch this if they replace their storage format and convert their entire model storage. bit of a huge task to run on their servers. i mean, they could protect the stuff if they introduce the new format for new assets, but the legacy format will always work to be ripped. they may eventually do that new thing and add a secondary data interpreter and renderer, but it's a coding task to do. til then it'll all work. :]
lame as fuck, right? :]

DictatorReg
ultra-n00b
Posts: 1
Joined: Fri Dec 28, 2018 5:07 pm

Re: WebGL ripping of a model from sketchfab

Post by DictatorReg » Fri Dec 28, 2018 5:30 pm

Hello, I'm trying to follow the posted tutorial (the download that comes with Blender and a tutorial folder) but when I try to import the file.osgjs, it doesn't do anything within Blender, the only thing that seems to happen is that a file.osgjs.ys file is created, but I'm not sure what that is.

I've tried running it as an admin, but that causes some kind of script error.

I've got the texture files, file.osgjs, model_file.bin and model_file_wireframe.bin in a folder and have file extensions shown.

This is what I'm trying to use (https://sketchfab.com/models/eb6973d71b ... 1fde4c81bb), but I'd prefer learning how to rip it.

episoder
mega-veteran
mega-veteran
Posts: 193
Joined: Fri Oct 16, 2015 8:05 pm
Has thanked: 4 times
Been thanked: 82 times

Re: WebGL ripping of a model from sketchfab

Post by episoder » Sat Dec 29, 2018 2:09 am

DictatorReg wrote:Hello, I'm trying to follow the posted tutorial (the download that comes with Blender and a tutorial folder) but when I try to import the file.osgjs, it doesn't do anything within Blender, the only thing that seems to happen is that a file.osgjs.ys file is created, but I'm not sure what that is.

I've tried running it as an admin, but that causes some kind of script error.

I've got the texture files, file.osgjs, model_file.bin and model_file_wireframe.bin in a folder and have file extensions shown.

This is what I'm trying to use (https://sketchfab.com/models/eb6973d71b ... 1fde4c81bb), but I'd prefer learning how to rip it.
works for me.

how big is the ys file you got? the one i got is 944.676 bytes. a smaller or perhaps empty file indicates the script not working. might aswell check the console for errors. also gotta ask which browser are you using? if you use the developer window in firefox you download the gz files. which you should not just save renamed. you gotta extract them with winrar. chrome decompresses the files automaticly, hence why it works. if you use chrome make sure to "safe as" the osgjs file. don't copypaste the text. the script does not compute the linebreaks in the text, this will not import either. :)

Laserschwert
ultra-n00b
Posts: 1
Joined: Thu Feb 26, 2015 10:17 pm

Re: WebGL ripping of a model from sketchfab

Post by Laserschwert » Sun Dec 30, 2018 12:04 am

Ah, too bad it doesn't work for me. Each time I run the script, select the file and click on import, the script throws an error. This is what shows up in the command line window:

Code: Select all

Traceback (most recent call last):
  File "starter.py", line 1767, in openFile
    parser=Parser()
  File "starter.py", line 1760, in Parser
    osgParser(filename)
  File "starter.py", line 1683, in osgParser
    model=Model(filename)
NameError: global name 'Model' is not defined
The error at the bottom seems to be the stopper here, right? Any idea what might cause this?

EDIT: Never mind, I got it working. If you don't install Blender (but just extract it from the extractor ZIP), you need to copy the folder "newGameLib" from the folder "blender/scripts" one folder up, so it lies directly in the "blender" folder. So instead of "blender/scripts/newGameLib" it should just be at "blender/newGameLib".

User avatar
M0fD
mega-veteran
mega-veteran
Posts: 192
Joined: Sat Nov 01, 2014 10:05 pm
Location: Les Gobelins
Has thanked: 19 times
Been thanked: 28 times

Re: WebGL ripping of a model from sketchfab

Post by M0fD » Mon Jan 07, 2019 1:35 am

Anyway, there is a solution to switch between "x" amount of Python version ^^
1. Ninja Ripper doesn't work with Sketchfab

2. Don't distribute the extraction method

3. Three models only

4. No buyable models


ImageImage

pendave
n00b
Posts: 13
Joined: Fri Jun 26, 2015 10:50 am
Has thanked: 1 time
Been thanked: 1 time

Re: WebGL ripping of a model from sketchfab

Post by pendave » Thu Jan 10, 2019 3:12 am

M0fD wrote:Anyway, there is a solution to switch between "x" amount of Python version ^^
wmic environment
pipenv
Which method do you use? :wink:

spliffiam
ultra-n00b
Posts: 2
Joined: Thu Jan 10, 2019 3:43 am

Re: WebGL ripping of a model from sketchfab

Post by spliffiam » Thu Jan 10, 2019 3:46 am

Hey so i ripped this model
https://www.artstation.com/artwork/xO3OR

Using this https://github.com/majimboo/mviewer

And the problem im having is that in my cinema4d or maya or whatever the UVs are not there and the normals are quite fucked if they are there.
Is this normal? Or am i doing something wrong here.

User avatar
M0fD
mega-veteran
mega-veteran
Posts: 192
Joined: Sat Nov 01, 2014 10:05 pm
Location: Les Gobelins
Has thanked: 19 times
Been thanked: 28 times

Re: WebGL ripping of a model from sketchfab

Post by M0fD » Thu Jan 10, 2019 4:32 am

pendave wrote:
M0fD wrote:Anyway, there is a solution to switch between "x" amount of Python version ^^
wmic environment
pipenv
Which method do you use? :wink:
Neither of them :-P
1. Ninja Ripper doesn't work with Sketchfab

2. Don't distribute the extraction method

3. Three models only

4. No buyable models


ImageImage

julioricardonuniez
ultra-n00b
Posts: 1
Joined: Tue Jan 08, 2019 9:31 pm
Has thanked: 1 time

Re: WebGL ripping of a model from sketchfab

Post by julioricardonuniez » Fri Jan 11, 2019 3:31 am

Hi, i have a problem with this model https://sketchfab.com/models/d4fc2ad99d ... c613bcf579
when i import to blender, the character is missing

Image

Post Reply