READ THE RULES: Click here

Follow us on Facebook: https://www.facebook.com/xentax/ :)

ARchive_neXt

The Original Forum. Game archives, full of resources. How to open them? Get help here.
User avatar
MichaelDarkAngel
mega-veteran
mega-veteran
Posts: 267
Joined: Thu Nov 04, 2010 11:25 pm
Location: Somewhere, out there... But, not quite here...
Has thanked: 133 times
Been thanked: 165 times
Contact:

Re: ARchive_neXt

Post by MichaelDarkAngel » Tue Mar 28, 2017 4:32 am

So... on the RSS image front

The issue I am having may have more to do with the Beta version of the game than I first thought. Some images work fine:
Image
Click for larger image

Others have issues:
Image
Click for larger image

In the image with issues, everything in the file is telling me the image should be 1024x1024. Well after hunting down all the referenced files (which is the first problem I mentioned in an earlier post, I forgot to give it the ability to search for all those required files), piecing them together to build the DDS file, something just isn't right. For one, file size didn't seem large enough for a 1024x1024 image. If I edit the DDS file with a hex editor and change the height and width to 512x512...
Image
Click for larger image

Looks good. Yeah, but everything tells me it should be 1024x1024. Back to the drawing board. In order to create an image file for RSS, there are four files required (maybe more, that could be one of the drawbacks of the Beta version). The header file, which references the other required files and provides some other information (height, width, and a few others). The referenced files are in reverse order (smallest mipmaps to largest). Each of the referenced files contain image data, height and width again, the size of the image data of the previous file(s). Well, that was the key. Looking at that bit of information for the image that works that size is zero, meaning, there have been no image data files prior to this one. Looking at that information for the image that doesn't work, that size is 524,288. There is quite a large chunk of the image file that is missing!!!

So all I can do right now is fix the issue that shouldn't have been an issue in the last release and see if that works for anyone with the full version of the game.
Image
MDA

Like TBotR on Facebook
ARchive_neXt v4.03.27.0 Now Available!

"I intend to leave a memory of myself in the minds of others."
Leonardo da Vinci,
disciple of experience

User avatar
MichaelDarkAngel
mega-veteran
mega-veteran
Posts: 267
Joined: Thu Nov 04, 2010 11:25 pm
Location: Somewhere, out there... But, not quite here...
Has thanked: 133 times
Been thanked: 165 times
Contact:

Re: ARchive_neXt

Post by MichaelDarkAngel » Tue Mar 28, 2017 4:42 am

Now Available!!!

ARchive_neXt v4.03.27.0


Better error handling of the DX10 conversion process (currently only applies to Ghost Recon:Wildlands and Rainbow Six Siege)
A fix to the Rainbow Six Siege search process when building DDS images

That is all... for now...
Image
MDA

Like TBotR on Facebook
ARchive_neXt v4.03.27.0 Now Available!

"I intend to leave a memory of myself in the minds of others."
Leonardo da Vinci,
disciple of experience

User avatar
MichaelDarkAngel
mega-veteran
mega-veteran
Posts: 267
Joined: Thu Nov 04, 2010 11:25 pm
Location: Somewhere, out there... But, not quite here...
Has thanked: 133 times
Been thanked: 165 times
Contact:

Re: ARchive_neXt

Post by MichaelDarkAngel » Tue Mar 28, 2017 5:05 am

ravenov wrote:infinit issues today, map displaced ?! i inverted the UV's and there is this map Offset
Image

same problem for Normal/Spec/Gloss/Diff
UVs are slightly off. I'll see if I can get that a little closer with the next update.
Image
MDA

Like TBotR on Facebook
ARchive_neXt v4.03.27.0 Now Available!

"I intend to leave a memory of myself in the minds of others."
Leonardo da Vinci,
disciple of experience

User avatar
Faithfullfaun
advanced
Posts: 71
Joined: Mon Nov 28, 2016 9:12 am
Has thanked: 50 times
Been thanked: 4 times

Re: ARchive_neXt

Post by Faithfullfaun » Tue Mar 28, 2017 10:59 am

I don't no if it happens to everyone but it happens to me
Error.jpg
You do not have the required permissions to view the files attached to this post.

User avatar
HeliosAI
mega-veteran
mega-veteran
Posts: 165
Joined: Wed Nov 17, 2010 2:57 pm
Has thanked: 148 times
Been thanked: 53 times

Re: ARchive_neXt

Post by HeliosAI » Tue Mar 28, 2017 11:27 am

Thanks a lot for the update, but sadly i still get the same errors. I disabled any sorts of UAC, am logged in as admin and have full acess to any folders archive next uses, also turned off anti virus but the errors are still there.

It's not a big issue for me personally as i don't mind exporting and looking through things, though.

merde10
ultra-n00b
Posts: 2
Joined: Wed Aug 10, 2016 7:59 pm

Re: ARchive_neXt

Post by merde10 » Tue Mar 28, 2017 11:54 am

Hey guys!

Thanks a lot for this amazing tool!

I'm actually ripping some models from assassin's creed 1 on PC.

I would like to know if is it possible to rip model with their location on the scene?

For example, i would like to rip the solomon temple, but all the assets are in the same location when i import them into blender(and it's really hard to find their real locations).

I tried with 3d ripper dx but i have no 3d capture ( the game launch but when i press the button, nothing happens...).

Thanks a lot! :)

ravenov
beginner
Posts: 24
Joined: Wed Mar 23, 2016 8:59 pm
Has thanked: 30 times
Been thanked: 4 times

Re: ARchive_neXt

Post by ravenov » Tue Mar 28, 2017 1:00 pm

MichaelDarkAngel wrote:
ravenov wrote:infinit issues today, map displaced ?! i inverted the UV's and there is this map Offset


same problem for Normal/Spec/Gloss/Diff
UVs are slightly off. I'll see if I can get that a little closer with the next update.
i hope you can fix the preview on the tool, having so much pain with splited parts...

User avatar
MichaelDarkAngel
mega-veteran
mega-veteran
Posts: 267
Joined: Thu Nov 04, 2010 11:25 pm
Location: Somewhere, out there... But, not quite here...
Has thanked: 133 times
Been thanked: 165 times
Contact:

Re: ARchive_neXt

Post by MichaelDarkAngel » Tue Mar 28, 2017 4:09 pm

Faithfullfaun wrote:I don't no if it happens to everyone but it happens to me
Is this happening with every image file?
ravenov wrote:i hope you can fix the preview on the tool, having so much pain with splited parts...
If the latest update did not fix the model viewer issue, texconv is not your only problem, and you are suffering from a problem that has plagued ARchive_neXt for a long time.
Image
MDA

Like TBotR on Facebook
ARchive_neXt v4.03.27.0 Now Available!

"I intend to leave a memory of myself in the minds of others."
Leonardo da Vinci,
disciple of experience

ravenov
beginner
Posts: 24
Joined: Wed Mar 23, 2016 8:59 pm
Has thanked: 30 times
Been thanked: 4 times

Re: ARchive_neXt

Post by ravenov » Tue Mar 28, 2017 6:28 pm

MichaelDarkAngel wrote:
Faithfullfaun wrote:I don't no if it happens to everyone but it happens to me
Is this happening with every image file?
ravenov wrote:i hope you can fix the preview on the tool, having so much pain with splited parts...
If the latest update did not fix the model viewer issue, texconv is not your only problem, and you are suffering from a problem that has plagued ARchive_neXt for a long time.
i don't know if this is possible can you add a search bare on the tool to find files names quicly ?
that will be really helpfull and replace the preview option !

User avatar
Faithfullfaun
advanced
Posts: 71
Joined: Mon Nov 28, 2016 9:12 am
Has thanked: 50 times
Been thanked: 4 times

Re: ARchive_neXt

Post by Faithfullfaun » Tue Mar 28, 2017 6:55 pm

MichaelDarkAngel wrote:
Faithfullfaun wrote:I don't no if it happens to everyone but it happens to me
Is this happening with every image file?
ravenov wrote:i hope you can fix the preview on the tool, having so much pain with splited parts...
If the latest update did not fix the model viewer issue, texconv is not your only problem, and you are suffering from a problem that has plagued ARchive_neXt for a long time.
Yes every single image i select :(

User avatar
MichaelDarkAngel
mega-veteran
mega-veteran
Posts: 267
Joined: Thu Nov 04, 2010 11:25 pm
Location: Somewhere, out there... But, not quite here...
Has thanked: 133 times
Been thanked: 165 times
Contact:

Re: ARchive_neXt

Post by MichaelDarkAngel » Tue Mar 28, 2017 8:00 pm

Faithfullfaun wrote:i don't know if this is possible can you add a search bare on the tool to find files names quicly ?
that will be really helpfull and replace the preview option !
Search is in the works, but most likely not until I'm further along with the new games.
Faithfullfaun wrote:Yes every single image i select :(
Sounds like they did in fact change something in the full version of the game. I may have to buy the game this weekend in order to fix this issue.
Image
MDA

Like TBotR on Facebook
ARchive_neXt v4.03.27.0 Now Available!

"I intend to leave a memory of myself in the minds of others."
Leonardo da Vinci,
disciple of experience

striking
ultra-n00b
Posts: 4
Joined: Fri Mar 10, 2017 11:14 am
Has thanked: 4 times
Been thanked: 1 time

Re: ARchive_neXt

Post by striking » Tue Mar 28, 2017 8:10 pm

MichaelDarkAngel wrote:So... on the RSS image front

The issue I am having may have more to do with the Beta version of the game than I first thought. Some images work fine:

...
I have the same issues with the full version.
Comparing the beta, Steam and UPlay files shows different file sizes for the same files. So they probably changed the
partition of the images. Additionally they changed some of the forge files with each update, including the largest difference
for the Ultra HD update.

striking
ultra-n00b
Posts: 4
Joined: Fri Mar 10, 2017 11:14 am
Has thanked: 4 times
Been thanked: 1 time

Re: ARchive_neXt

Post by striking » Wed Mar 29, 2017 12:07 pm

Would it be of any help if you have a forge file together with some of the DDS-textures obtained from NinjaRipper ?

User avatar
MichaelDarkAngel
mega-veteran
mega-veteran
Posts: 267
Joined: Thu Nov 04, 2010 11:25 pm
Location: Somewhere, out there... But, not quite here...
Has thanked: 133 times
Been thanked: 165 times
Contact:

Re: ARchive_neXt

Post by MichaelDarkAngel » Wed Mar 29, 2017 12:59 pm

striking wrote:Would it be of any help if you have a forge file together with some of the DDS-textures obtained from NinjaRipper ?
Each piece of the image is in a different forge file. So, with the beta version, that makes 4 forge files. Being that a piece is missing, it's possibly in another forge file. I'll have the game tomorrow or Friday at the latest.

In the meantime, I'm working on the search function and adding the index system to the older games.
Image
MDA

Like TBotR on Facebook
ARchive_neXt v4.03.27.0 Now Available!

"I intend to leave a memory of myself in the minds of others."
Leonardo da Vinci,
disciple of experience

ravenov
beginner
Posts: 24
Joined: Wed Mar 23, 2016 8:59 pm
Has thanked: 30 times
Been thanked: 4 times

Re: ARchive_neXt

Post by ravenov » Thu Mar 30, 2017 3:15 pm

MichaelDarkAngel wrote:
striking wrote:Would it be of any help if you have a forge file together with some of the DDS-textures obtained from NinjaRipper ?
Each piece of the image is in a different forge file. So, with the beta version, that makes 4 forge files. Being that a piece is missing, it's possibly in another forge file. I'll have the game tomorrow or Friday at the latest.

In the meantime, I'm working on the search function and adding the index system to the older games.
when i try to export a mesh this Error message pop-up / and when i let the tool for a moment or changing the window and i try again it works correctly, but again for some reason this error will pop-up again trying epxorting a mesh...

Image

Code: Select all

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
   at ARchive_neXt.arxForm.arxExportOBJ(TreeNode tNode, String savePath)
   at ARchive_neXt.arxForm.arxExportModels(String fileExt)
   at ARchive_neXt.arxForm.tsmiExportModels_Click(Object sender, EventArgs e)
   at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
   at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
   at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.ToolStrip.WndProc(Message& m)
   at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
ARchive_neXt
    Assembly Version: 4.3.27.0
    Win32 Version: 4.03.27.0
    CodeBase: file:///C:/Program%20Files%20(x86)/TBotR/ARchive_neXt/ARchive_neXt.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Microsoft.DirectX
    Assembly Version: 1.0.2902.0
    Win32 Version: 5.04.00.2904
    CodeBase: file:///C:/Windows/assembly/GAC/Microsoft.DirectX/1.0.2902.0__31bf3856ad364e35/Microsoft.DirectX.dll
----------------------------------------
Microsoft.DirectX.Direct3D
    Assembly Version: 1.0.2902.0
    Win32 Version: 9.05.132.0000
    CodeBase: file:///C:/Windows/assembly/GAC/Microsoft.DirectX.Direct3D/1.0.2902.0__31bf3856ad364e35/Microsoft.DirectX.Direct3D.dll
----------------------------------------
Microsoft.DirectX.Direct3DX
    Assembly Version: 1.0.2911.0
    Win32 Version: 9.12.589.0000
    CodeBase: file:///C:/Windows/assembly/GAC/Microsoft.DirectX.Direct3DX/1.0.2911.0__31bf3856ad364e35/Microsoft.DirectX.Direct3DX.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
ArchiveX
    Assembly Version: 4.2.3.0
    Win32 Version: 4.02.03.0
    CodeBase: file:///C:/Program%20Files%20(x86)/TBotR/ARchive_neXt/ArchiveX.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
*Figured out

Post Reply