XeNTaX Forum Index
Forum MultiEx Commander Tools Tools Home
It is currently Sat Sep 23, 2017 3:46 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Ninjaripper 1.6 & Sketchfab UV coordinate and mesh problem
PostPosted: Fri Feb 10, 2017 3:02 am 
Offline
ultra-n00b

Joined: Fri Feb 10, 2017 2:33 am
Posts: 6
Has thanked: 1 time
Have thanks: 0 time














You can make the ads go away by registering

Hi guys
I have an issue with some ripped models from sketchfab, I am ripping some characters to polish my topology modeling skills and coz some are awesome.
But sometimes after I rip with ninjaripper 1.6 either from Firefox 64bit or Chrome 64bit, some models are totally missing UV coordinates.

I use the method of loading the link of the model im having issue with btw: sketchfab.com/models/c8ae1eeba2384a95a4d4cce3ee20e168/embed
then going fullscreen and rotating the model 360 degrees. I rip with F12, sometimes the inspector panel comes up highlighting a line of code (dont know)
but the ripping of the model succeeds with textures.

Now i load up max 2016 and use ninjaripper 1.3 script to import with the parameters for U and V at 3 and 4 and Flip UV turned on.

It loads all the meshes, sometimes duplicates from which 1-2 have UV coordinates the other 3 doesnt.
Sometimes the mesh is full of missing polygons and has holes scattered throughout. Its not even in a separate rip file which sometimes happens.
That is a bitch to manually fill and adjust weld the new poly UV`s in UVW Unwrapper.

I use Intruder rip in 64 bit because the DX11 Wrapper says it cant create the directory for ninjaripper .

The weird thing is that the same model for example the hair, bikini, eyes, shoes have UV coordinates....the rest like body face does not

Can anyone help me with this issue? Any similar issues out there?
For example some paid sketchfab models import perfectly with UV albeit with holes.....and artstation marmoset viewer models also rip perfectly, no holes, no UV errors. Just copy the embed code and open it in a new tab.

Heres is the link again: sketchfab.com/models/c8ae1eeba2384a95a4d4cce3ee20e168#

Cheers and happy ripping


Attachments:


You do not have the required permissions to view the files attached to this post. Register to gain access.



Top
 Profile  
 
 Post subject: Re: Ninjaripper 1.6 & Sketchfab UV coordinate and mesh probl
PostPosted: Fri Feb 10, 2017 7:04 am 
Offline
ultra-n00b

Joined: Fri Feb 10, 2017 2:33 am
Posts: 6
Has thanked: 1 time
Have thanks: 0 time
I also tried with GIMS that came with Ninjaripper and followed the directions from another post precisely. Same result. Nothing. The UV coordinates seem to not exist.
Help would be great, I dont care about the holes because i dont need to render this or anything, but uv coordinates would be great so i know where the seams are cut and how to unwrap a character.


Top
 Profile  
 
 Post subject: Re: Ninjaripper 1.6 & Sketchfab UV coordinate and mesh probl
PostPosted: Fri Feb 10, 2017 8:28 am 
Offline
advanced

Joined: Wed Nov 28, 2012 11:55 am
Posts: 77
Has thanked: 0 time
Have thanks: 64 times
http://cgig.ru/en/2017/01/ninja-ripper- ... /#more-916

And
Unwrap UV in 3D MAX

_________________
Have a question about NinjaRipper? Ask on forum, not PM.


Top
 Profile  
 
 Post subject: Re: Ninjaripper 1.6 & Sketchfab UV coordinate and mesh probl
PostPosted: Fri Feb 10, 2017 11:35 am 
Offline
ultra-n00b

Joined: Fri Feb 10, 2017 2:33 am
Posts: 6
Has thanked: 1 time
Have thanks: 0 time
thanks, will try as per the link. cheers for that


Top
 Profile  
 
 Post subject: Re: Ninjaripper 1.6 & Sketchfab UV coordinate and mesh probl
PostPosted: Sat Feb 11, 2017 9:36 am 
Offline
ultra-n00b

Joined: Fri Feb 10, 2017 2:33 am
Posts: 6
Has thanked: 1 time
Have thanks: 0 time
So I tried exactly as it stated on the site, even with GIMS Evo doing auto UV assignment (it doesnt generate or put it on different UV channels) and I tried the 3dsmax script import with UV 3-4 still nothing.
Though now it did get the hair mesh and filled the holes (hair and iris UV is good now) rest is not. Now even the face or clothes dont have UV

Weird....I think i give up....unless someone can try the link


Attachments:


You do not have the required permissions to view the files attached to this post. Register to gain access.



Top
 Profile  
 
 Post subject: Re: Ninjaripper 1.6 & Sketchfab UV coordinate and mesh probl
PostPosted: Sat Feb 11, 2017 5:39 pm 
Offline
veteran

Joined: Wed Jun 17, 2009 4:33 pm
Posts: 116
Has thanked: 19 times
Have thanks: 4 times
Make sure the textured mesh isn't overlapped by a mesh without textures

select the face and move it just to be sure


Top
 Profile  
 
 Post subject: Re: Ninjaripper 1.6 & Sketchfab UV coordinate and mesh probl
PostPosted: Sat Feb 11, 2017 6:11 pm 
Offline
ultra-n00b

Joined: Fri Feb 10, 2017 2:33 am
Posts: 6
Has thanked: 1 time
Have thanks: 0 time
yepp, did that. Nothing. Weird thing is that the same method i used before now produced different results. Now some parts that had UV now dont have.
Can the UV somehow be locked?? Unrippable? But other models come out perfect, so its weird.
Whats the best method? Firefox, Chrome? 32 vs 64 bit? Intruder, DX11, DX9 rip? Ninjaripper import script or GIMS EvO?? Do these contribute to the end result?
Let me know guys THANKS!!!


Top
 Profile  
 
 Post subject: Re: Ninjaripper 1.6 & Sketchfab UV coordinate and mesh probl
PostPosted: Sat Feb 11, 2017 7:44 pm 
Offline
veteran

Joined: Wed Jun 17, 2009 4:33 pm
Posts: 116
Has thanked: 19 times
Have thanks: 4 times
If you end up with incomplete meshes, I would recommend setting the forced rip interval time setting according to the size of the model

for example if the mesh is very large like 1 MB, I'd try a 60 second setting to be sure it'll capture everything


Top
 Profile  
 
 Post subject: Re: Ninjaripper 1.6 & Sketchfab UV coordinate and mesh probl
PostPosted: Mon Feb 13, 2017 3:57 am 
Offline
ultra-n00b

Joined: Fri Feb 10, 2017 2:33 am
Posts: 6
Has thanked: 1 time
Have thanks: 0 time
Modman69 thanks for the tip, i never thought increasing the interval time would do anything.
Ok it ripped 997 rip files but it worked, mid 800`s meshes were perfect, UV coordinates on everything, filled holes by small triangles also merged with the model. Imported with GIMS Evo.
Thanks a million guys, im guessing it will work from now on.

cheers


Top
 Profile  
 
 Post subject: Re: Ninjaripper 1.6 & Sketchfab UV coordinate and mesh probl
PostPosted: Wed Jul 05, 2017 11:02 pm 
Offline
ultra-n00b

Joined: Sat Jun 17, 2017 5:41 pm
Posts: 4
Has thanked: 0 time
Have thanks: 0 time
Im having trouble with this model
https://sketchfab.com/models/cd3d5b46f8 ... 9c90/embed

It comes out sort of gray scale but it looks like the uvs arnt quite right either

Im guessing that the textures used here are actually grayscale and it has material colors applied to it
Any way to retain the material color if this is the case?

how im doing this is using firefox x64 with it set to d3d9(d3d11 dosnt seem to work for me, no models or textures are produced when i press f12 nor dose it freeze when i press f12 like its mean to) opening the .rip in noesis and exporting to obj and then opening it in blender

Anybody got any ideas what i can do, i can always do the material color my self but it looks like the uvs arnt correct so i wonder if im doing something wrong :/


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group