XeNTaX Forum Index
Forum MultiEx Commander Tools Tools Home
It is currently Sun Mar 26, 2017 2:32 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Need help reconstructing .VSP file
PostPosted: Tue Aug 23, 2016 7:27 pm 
Offline
n00b

Joined: Sun Nov 23, 2014 2:07 am
Posts: 15
Has thanked: 3 times
Have thanks: 1 time

Hi, the mentioned file in the subject is a project file from a video editing software called Corel Video Studio.

I opened that project file with the standard Microsoft editor, because i wanted to edit the drive letter of the root path from a certain video file,
due to a relink problem with that video file in the Video Studio software.
After I saved it, it won't open anymore in Video Studio because the text editor replaced all hexadecimal 00's with 20's in that project file...

Image

The thing is, that it's a very big file. It's about 5mb, and as I said all 00's were replaced :(

What I tried to do, to "repair" that file was to replace all 20's with 00's again
and then to find out the specific offsets where any 20's were needed, in order Video Studio to load that project file again..

I found that offsets through comparison with an older save of that project file.

I partially had success after all that 00 replacements with the 20's, Video Studio loads the project file again but it gets stuck at 68%.

I have a guess at which offset it get's stuck, but the bytes at that offset seem ok to me if I indicate the pattern right..

It should be got stuck at offset 0x0D5600:
Image

If someone could help me, giving me some advice if there's any pointers or sth. else important to know in that specific byte block where that pattern is visible, I really would appreciate it.

Thx very much in advice.

edit:

Well, the project file loads up again now. There was a nullbyte at 0x3f05fd that had to be replaced also with "20".

Image

But unfortunalley, I guess there have to be replaced some more nullbytes with "20"'s, because if you press the play button
yout get the error message "It has been detected a wrong argument"..

Image

Any advice, which bytes are responible for passing this or these arguments would be very apreciated...

You can make the ads go away by registering





Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group